3 f÷ÔY9ã@sldZddlmZddlZddlZdZefZy eefZWne k rJYnXye Z Wn$e k rxe Z e e kstt‚YnXdOdkrŒdd„Zndd„Zy ejZWnek rºd d „ZYnXd d „Zeed ƒrØdd„Zndd„ZdPdd„ZGdd„deƒZdZdZGdd„deƒZGdd„deƒZdd„ZdQdd „Zd!d"„Z d#d$„Z!d%d&„Z"d'd(„Z#d)d*„Z$d+d,„Z%d-d.„Z&d/d0„Z'd1d2„Z(d3d4„Z)Gd5d6„d6eƒZ*Gd7d8„d8e*ƒZ+Gd9d:„d:e*ƒZ,Gd;d<„d„d>e-e+ƒZ.Gd?d@„d@e.ƒZ/GdAdB„dBe-e,ƒZ0GdCdD„dDeƒZ1e1e._2GdEdF„dFeƒZ3GdGdH„dHe3e+ƒZ4GdIdJ„dJe4ƒZ5GdKdL„dLe3e,ƒZ6GdMdN„dNeƒZ7e7e4_2dS)Rz•A fast, lightweight IPv4/IPv6 manipulation library in Python. This library is used to create/poke/manipulate IPv4 and IPv6 addresses and networks. é)Úunicode_literalsNz1.0.18ócCs|S)N©)Úbytrrú:/Users/olari/OneDrive/sandbox/awsBlog2/lambda/ipaddress.pyÚ_compat_bytes_to_byte_valssrcCsdd„|DƒS)NcSsg|]}tjd|ƒd‘qS)s!Br)ÚstructÚunpack)Ú.0Úbrrrú #sz._compat_bytes_to_byte_vals..r)rrrrr"scCs<|dks t‚d}x&|D]}t|tƒs(t‚|d>|}qW|S)NÚbigré)ÚAssertionErrorÚ isinstanceÚ_compat_int_types)ZbytvalsÚ endianessÚresZbvrrrÚ_compat_int_from_byte_vals's   rcCsŠt|tƒst‚|dkst‚|dkrH|dks2|dkr7}|d|j kr„Pq„WdS) a¤Summarize a network range given the first and last IP addresses. Example: >>> list(summarize_address_range(IPv4Address('192.0.2.0'), ... IPv4Address('192.0.2.130'))) ... #doctest: +NORMALIZE_WHITESPACE [IPv4Network('192.0.2.0/25'), IPv4Network('192.0.2.128/31'), IPv4Network('192.0.2.130/32')] Args: first: the first IPv4Address or IPv6Address in the range. last: the last IPv4Address or IPv6Address in the range. Returns: An iterator of the summarized IPv(4|6) network objects. Raise: TypeError: If the first and last objects are not IP addresses. If the first and last objects are not the same version. ValueError: If the last object is not greater than the first. If the version of the first address is not 4 or 6. z1first and last must be IP addresses, not networksz%%s and %s are not of the same versionz*last IP address must be greater than firstrézunknown IP versionr%N) rÚ _BaseAddressÚ TypeErrorÚversionr@rCrDÚ_max_prefixlenrUr\r^r"Ú _ALL_ONES)rXrYrZZip_bitsZ first_intZlast_intZnbitsÚnetrrrÚsummarize_address_rangeBs0         rfccs˜t|ƒ}i}xL|rX|jƒ}|jƒ}|j|ƒ}|dkr>|||<q||kr||=|j|ƒqWd}x4t|jƒƒD]$}|dk r†|j|jkr†ql|V|}qlWdS)auLoops through the addresses, collapsing concurrent netblocks. Example: ip1 = IPv4Network('192.0.2.0/26') ip2 = IPv4Network('192.0.2.64/26') ip3 = IPv4Network('192.0.2.128/26') ip4 = IPv4Network('192.0.2.192/26') _collapse_addresses_internal([ip1, ip2, ip3, ip4]) -> [IPv4Network('192.0.2.0/24')] This shouldn't be called directly; it is called via collapse_addresses([]). Args: addresses: A list of IPv4Network's or IPv6Network's Returns: A list of IPv4Network's or IPv6Network's depending on what we were passed. N)ÚlistÚpopÚsupernetÚgetÚappendÚsortedÚvaluesÚbroadcast_address)rVZto_mergeÚsubnetsreriZexistingrYrrrÚ_collapse_addresses_internalys$   rpc Cs8g}g}g}xä|D]Ü}t|tƒrT|rH|dj|jkrHtd||dfƒ‚|j|ƒq|j|jkr¼|rˆ|dj|jkrˆtd||dfƒ‚y|j|jƒWqîtk r¸|j|j ƒYqîXq|rä|dj|jkrätd||dfƒ‚|j|ƒqWt t |ƒƒ}|�r,x&t |ƒD]\}}|j t||ƒƒ�qWt||ƒS) aËCollapse a list of IP objects. Example: collapse_addresses([IPv4Network('192.0.2.0/25'), IPv4Network('192.0.2.128/25')]) -> [IPv4Network('192.0.2.0/24')] Args: addresses: An iterator of IPv4Network or IPv6Network objects. Returns: An iterator of the collapsed IPv(4|6)Network objects. Raises: TypeError: If passed a list of mixed version objects. r%z%%s and %s are not of the same versionéÿÿÿÿrqrqrqrqrq)rr`Ú_versionrarkÚ _prefixlenrcrZÚAttributeErrorÚnetwork_addressrlÚsetr[Úextendrfrp)rVZaddrsZipsZnetsrZrXrYrrrÚcollapse_addressesªs4     rxcCs(t|tƒr|jƒSt|tƒr$|jƒStS)a2Return a key suitable for sorting between networks and addresses. Address and Network objects are not sortable by default; they're fundamentally different so the expression IPv4Address('192.0.2.0') <= IPv4Network('192.0.2.0/24') doesn't make any sense. There are some times however, where you may wish to have ipaddress sort these for you anyway. If you need to do this, you can use this function as the key= argument to sorted(). Args: obj: either a Network or Address object. Returns: appropriate key. )rÚ _BaseNetworkÚ_get_networks_keyr`Ú_get_address_keyr.)ÚobjrrrÚget_mixed_type_keyàs   r}c@s˜eZdZdZfZedd„ƒZedd„ƒZedd„ƒZedd „ƒZ d d „Z d d „Z e dd„ƒZ e dd„ƒZe dd„ƒZe dd„ƒZe dd„ƒZdd„ZdS)Ú_IPAddressBasezThe mother class.cCs|jƒS)z:Return the longhand version of the IP address as a string.)Ú_explode_shorthand_ip_string)r+rrrÚexplodedÿsz_IPAddressBase.explodedcCst|ƒS)z;Return the shorthand version of the IP address as a string.)rN)r+rrrÚ compressedsz_IPAddressBase.compressedcCs|jƒS)aIThe name of the reverse DNS pointer for the IP address, e.g.: >>> ipaddress.ip_address("127.0.0.1").reverse_pointer '1.0.0.127.in-addr.arpa' >>> ipaddress.ip_address("2001:db8::1").reverse_pointer '1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.8.b.d.0.1.0.0.2.ip6.arpa' )Ú_reverse_pointer)r+rrrÚreverse_pointer s z_IPAddressBase.reverse_pointercCsdt|ƒf}t|ƒ‚dS)Nz%200s has no version specified)Útyper)r+Úmsgrrrrbsz_IPAddressBase.versioncCsF|dkrd}t|||jfƒ‚||jkrBd}t|||j|jfƒ‚dS)Nrz-%d (< 0) is not permitted as an IPv%d addressz2%d (>= 2**%d) is not permitted as an IPv%d address)r:rrrdrc)r+rAr…rrrÚ_check_int_addresss  z!_IPAddressBase._check_int_addresscCs.t|ƒ}||kr*d}t|||||jfƒ‚dS)Nz~%r (len %d != %d) is not permitted as an IPv%d address. Did you pass in a bytes (str in Python 2) instead of a unicode object?)rPr:rr)r+rAZ expected_lenZ address_lenr…rrrÚ_check_packed_address"s z$_IPAddressBase._check_packed_addresscCs|j|j|?AS)z¦Turn the prefix length into a bitwise netmask Args: prefixlen: An integer, the prefix length. Returns: An integer. )rd)ÚclsÚ prefixlenrrrÚ_ip_int_from_prefix,s z"_IPAddressBase._ip_int_from_prefixc Cs\t||jƒ}|j|}||?}d|>d}||krX|jd}t||dƒ}d}t||ƒ‚|S)aReturn prefix length from the bitwise netmask. Args: ip_int: An integer, the netmask in expanded bitwise format Returns: An integer, the prefix length. Raises: ValueError: If the input intermingles zeroes & ones r%rr z&Netmask pattern %r mixes zeroes & ones)r^rcrr@) rˆÚip_intZtrailing_zeroesr‰Z leading_onesZall_onesZbyteslenÚdetailsr…rrrÚ_prefix_from_ip_int9s      z"_IPAddressBase._prefix_from_ip_intcCsd|}t|ƒ‚dS)Nz%r is not a valid netmask)r<)rˆZ netmask_strr…rrrÚ_report_invalid_netmaskRsz&_IPAddressBase._report_invalid_netmaskc Csjtjj|ƒs|j|ƒy t|ƒ}Wntk r@|j|ƒYnXd|koV|jknsf|j|ƒ|S)a Return prefix length from a numeric string Args: prefixlen_str: The string to be converted Returns: An integer, the prefix length. Raises: NetmaskValueError: If the input is not a valid netmask r)Ú_BaseV4Ú_DECIMAL_DIGITSÚ issupersetrŽÚintr@rc)rˆZ prefixlen_strr‰rrrÚ_prefix_from_prefix_stringWs    z)_IPAddressBase._prefix_from_prefix_stringcCs†y|j|ƒ}Wntk r,|j|ƒYnXy |j|ƒStk rLYnX||jN}y |j|ƒStk r€|j|ƒYnXdS)aTurn a netmask/hostmask string into a prefix length Args: ip_str: The netmask/hostmask to be converted Returns: An integer, the prefix length. Raises: NetmaskValueError: If the input is not a valid netmask/hostmask N)Ú_ip_int_from_stringr:rŽr�r@rd)rˆÚip_strr‹rrrÚ_prefix_from_ip_stringps   z%_IPAddressBase._prefix_from_ip_stringcCs|jt|ƒffS)N)Ú __class__rN)r+rrrÚ __reduce__’sz_IPAddressBase.__reduce__N)r6r7r8r;r9Úpropertyr€r�rƒrbr†r‡Ú classmethodrŠr�rŽr“r–r˜rrrrr~ùs        "r~c@sdeZdZdZfZdd„Zdd„Zdd„Zdd „Zd d „Z d d „Z dd„Z dd„Z dd„Z dd„ZdS)r`z€A generic IP object. This IP class contains the version independent methods which are used by single IP addresses. cCs|jS)N)rU)r+rrrÚ__int__ sz_BaseAddress.__int__c Cs2y|j|jko|j|jkStk r,tSXdS)N)rUrrrtr.)r+r,rrrr-£s   z_BaseAddress.__eq__cCs`t|tƒstSt|tƒs(td||fƒ‚|j|jkrDtd||fƒ‚|j|jkr\|j|jkSdS)Nz"%s and %s are not of the same typez%%s and %s are not of the same versionF)rr~r.r`rarrrU)r+r,rrrr1ªs       z_BaseAddress.__lt__cCs t|tƒstS|jt|ƒ|ƒS)N)rrr.r—r’)r+r,rrrÚ__add__¹s z_BaseAddress.__add__cCs t|tƒstS|jt|ƒ|ƒS)N)rrr.r—r’)r+r,rrrÚ__sub__¾s z_BaseAddress.__sub__cCsd|jjt|ƒfS)Nz%s(%r))r—r6rN)r+rrrÚ__repr__Ãsz_BaseAddress.__repr__cCst|j|jƒƒS)N)rNÚ_string_from_ip_intrU)r+rrrÚ__str__Æsz_BaseAddress.__str__cCsttt|jƒƒƒS)N)ÚhashÚhexr’rU)r+rrrÚ__hash__Ész_BaseAddress.__hash__cCs |j|fS)N)rr)r+rrrr{Ìsz_BaseAddress._get_address_keycCs|j|jffS)N)r—rU)r+rrrr˜Ïsz_BaseAddress.__reduce__N)r6r7r8r;r9r›r-r1rœr�ržr r£r{r˜rrrrr`–sr`c@sXeZdZdZdd„Zdd„Zdd„Zdd „Zd d „Zd d „Z dd„Z dd„Z dd„Z dd„Z dd„Zedd„ƒZedd„ƒZedd„ƒZedd„ƒZed d!„ƒZed"d#„ƒZed$d%„ƒZed&d'„ƒZd(d)„Zd*d+„Zd,d-„ZdFd0d1„ZdGd2d3„Zed4d5„ƒZd6d7„Zd8d9„Zed:d;„ƒZ edd?„ƒZ"ed@dA„ƒZ#edBdC„ƒZ$edDdE„ƒZ%d/S)Hryz~A generic IP network object. This IP class contains the version independent methods which are used by networks. cCs i|_dS)N)Ú_cache)r+rArrrÚ__init__Ûsz_BaseNetwork.__init__cCsd|jjt|ƒfS)Nz%s(%r))r—r6rN)r+rrrržÞsz_BaseNetwork.__repr__cCsd|j|jfS)Nz%s/%d)rur‰)r+rrrr ász_BaseNetwork.__str__ccs<t|jƒ}t|jƒ}x"t|d|ƒD]}|j|ƒVq$WdS)zŸGenerate Iterator over usable hosts in a network. This is like __iter__ except it doesn't return the network or broadcast addresses. r%N)r’rurnr)Ú_address_class)r+ÚnetworkÚ broadcastÚxrrrÚhostsäs  z_BaseNetwork.hostsccs<t|jƒ}t|jƒ}x"t||dƒD]}|j|ƒVq$WdS)Nr%)r’rurnr)r¦)r+r§r¨r©rrrÚ__iter__ðs  z_BaseNetwork.__iter__cCslt|jƒ}t|jƒ}|dkr>|||kr0tdƒ‚|j||ƒS|d7}|||krZtdƒ‚|j||ƒSdS)Nrzaddress out of ranger%)r’rurnÚ IndexErrorr¦)r+Únr§r¨rrrÚ __getitem__ös    z_BaseNetwork.__getitem__cCsxt|tƒstSt|tƒs(td||fƒ‚|j|jkrDtd||fƒ‚|j|jkr\|j|jkS|j|jkrt|j|jkSdS)Nz"%s and %s are not of the same typez%%s and %s are not of the same versionF)rr~r.ryrarrruÚnetmask)r+r,rrrr1s         z_BaseNetwork.__lt__c CsFy,|j|jko,|j|jko,t|jƒt|jƒkStk r@tSXdS)N)rrrur’r¯rtr.)r+r,rrrr-s   z_BaseNetwork.__eq__cCstt|jƒt|jƒAƒS)N)r¡r’rur¯)r+rrrr£sz_BaseNetwork.__hash__cCsL|j|jkrdSt|tƒrdSt|jƒt|jƒkoBt|jƒkSSdS)NF)rrrryr’rurUrn)r+r,rrrÚ __contains__s   z_BaseNetwork.__contains__cCs(|j|kp&|j|kp&|j|kp&|j|kS)z*Tell if self is partly contained in other.)rurn)r+r,rrrÚoverlaps*s   z_BaseNetwork.overlapscCs<|jjdƒ}|dkr8|jt|jƒt|jƒBƒ}||jd<|S)Nrn)r¤rjr¦r’ruÚhostmask)r+r©rrrrn1s    z_BaseNetwork.broadcast_addresscCs8|jjdƒ}|dkr4|jt|jƒ|jAƒ}||jd<|S)Nr²)r¤rjr¦r’r¯rd)r+r©rrrr²:s   z_BaseNetwork.hostmaskcCsd|j|jfS)Nz%s/%d)rurs)r+rrrÚwith_prefixlenBsz_BaseNetwork.with_prefixlencCsd|j|jfS)Nz%s/%s)rur¯)r+rrrÚ with_netmaskFsz_BaseNetwork.with_netmaskcCsd|j|jfS)Nz%s/%s)rur²)r+rrrÚ with_hostmaskJsz_BaseNetwork.with_hostmaskcCst|jƒt|jƒdS)z&Number of hosts in the current subnet.r%)r’rnru)r+rrrÚ num_addressesNsz_BaseNetwork.num_addressescCsdt|ƒf}t|ƒ‚dS)Nz%%200s has no associated address class)r„r)r+r…rrrr¦Ssz_BaseNetwork._address_classcCs|jS)N)rs)r+rrrr‰[sz_BaseNetwork.prefixlenccs|j|jkstd||fƒ‚t|tƒs2td|ƒ‚|j|ƒsLtd||fƒ‚||krXdS|jd|j|jfƒ}|j ƒ\}}xb||krÜ||krÜ|j|ƒrª|V|j ƒ\}}q||j|ƒrÈ|V|j ƒ\}}q|t d|||fƒ‚q|W||krî|Vn$||k�r|Vnt d|||fƒ‚dS)aºRemove an address from a larger block. For example: addr1 = ip_network('192.0.2.0/28') addr2 = ip_network('192.0.2.1/32') list(addr1.address_exclude(addr2)) = [IPv4Network('192.0.2.0/32'), IPv4Network('192.0.2.2/31'), IPv4Network('192.0.2.4/30'), IPv4Network('192.0.2.8/29')] or IPv6: addr1 = ip_network('2001:db8::1/32') addr2 = ip_network('2001:db8::1/128') list(addr1.address_exclude(addr2)) = [ip_network('2001:db8::1/128'), ip_network('2001:db8::2/127'), ip_network('2001:db8::4/126'), ip_network('2001:db8::8/125'), ... ip_network('2001:db8:8000::/33')] Args: other: An IPv4Network or IPv6Network object of the same type. Returns: An iterator of the IPv(4|6)Network objects which is self minus other. Raises: TypeError: If self and other are of differing address versions, or if other is not a network object. ValueError: If other is not completely contained by self. z%%s and %s are not of the same versionz%s is not a network objectz%s not contained in %sNz%s/%sz3Error performing exclusion: s1: %s s2: %s other: %s) rrrarryÚ subnet_ofr@r—rur‰ror)r+r,Ús1Ús2rrrÚaddress_exclude_s6$           z_BaseNetwork.address_excludecCs`|j|jkrtd||fƒ‚|j|jkr,dS|j|jkr other eg: IPv4Network('192.0.2.128/25') > IPv4Network('192.0.2.0/25') IPv6Network('2001:db8::2000/124') > IPv6Network('2001:db8::1000/124') Raises: TypeError if the IP versions are different. z"%s and %s are not of the same typer%rrqrq)rrrarur¯)r+r,rrrÚcompare_networksªs!      z_BaseNetwork.compare_networkscCs|j|j|jfS)zËNetwork-only key function. Returns an object that identifies this address' network and netmask. This function is a suitable "key" argument for sorted() and list.sort(). )rrrur¯)r+rrrrzÚsz_BaseNetwork._get_networks_keyr%Nc csÖ|j|jkr|VdS|dk rJ||jkr0tdƒ‚|dkr@tdƒ‚||j}|dkrZtdƒ‚|j|}||jkr~td||fƒ‚t|jƒ}t|jƒd}t|jƒd|?}x(t|||ƒD]}|j||fƒ}|Vq¶WdS)aÓThe subnets which join to make the current subnet. In the case that self contains only one IP (self._prefixlen == 32 for IPv4 or self._prefixlen == 128 for IPv6), yield an iterator with just ourself. Args: prefixlen_diff: An integer, the amount the prefix length should be increased by. This should not be set if new_prefix is also set. new_prefix: The desired new prefix length. This must be a larger number (smaller prefix) than the existing prefix. This should not be set if prefixlen_diff is also set. Returns: An iterator of IPv(4|6) objects. Raises: ValueError: The prefixlen_diff is too small or too large. OR prefixlen_diff and new_prefix are both set or new_prefix is a smaller number than the current prefix (smaller number means a larger network) Nznew prefix must be longerr%z(cannot set prefixlen_diff and new_prefixrzprefix length diff must be > 0z0prefix length diff %d is invalid for netblock %s) rsrcr@r’rurnr²r)r—) r+Úprefixlen_diffÚ new_prefixÚ new_prefixlenr&r'r(Znew_addrÚcurrentrrrroäs,       z_BaseNetwork.subnetscCsˆ|jdkr|S|dk rB||jkr(tdƒ‚|dkr8tdƒ‚|j|}|j|}|dkrftd|j|fƒ‚|jt|jƒt|jƒ|>@|fƒS)aËThe supernet containing the current network. Args: prefixlen_diff: An integer, the amount the prefix length of the network should be decreased by. For example, given a /24 network and a prefixlen_diff of 3, a supernet with a /21 netmask is returned. Returns: An IPv4 network object. Raises: ValueError: If self.prefixlen - prefixlen_diff < 0. I.e., you have a negative prefix length. OR If prefixlen_diff and new_prefix are both set or new_prefix is a larger number than the current prefix (larger number means a smaller network) rNznew prefix must be shorterr%z(cannot set prefixlen_diff and new_prefixz;current prefixlen is %d, cannot have a prefixlen_diff of %d)rsr@r‰r—r’rur¯)r+r¼r½r¾rrrris     z_BaseNetwork.supernetcCs|jjo|jjS)z»Test if the address is reserved for multicast use. Returns: A boolean, True if the address is a multicast address. See RFC 2373 2.7 for details. )ruÚ is_multicastrn)r+rrrrÀAs z_BaseNetwork.is_multicastcCsP|j|jkrdSt|dƒr 255) not permitted)r@r�r‘rPr’)rˆZ octet_strr…Z octet_intrrrrÖýs       z_BaseV4._parse_octetcCsdjdd„t|ddƒDƒƒS)zÒTurns a 32-bit integer into dotted decimal notation. Args: ip_int: An integer, the IP address. Returns: The IP address as a string in dotted decimal notation. rÔcss0|](}tt|tƒr"tjd|ƒdn|ƒVqdS)s!BrN)rNrr?rr )r r rrrú -sz._BaseV4._string_from_ip_int..rr )Újoinr)rˆr‹rrrrŸ"s z_BaseV4._string_from_ip_intc sh|jdƒ}y‡fdd„tt|ƒDƒ}Wntk r:dSXt|ƒt|ƒkrPdS|d|dkrddSdS) zÙTest if the IP string is a hostmask (rather than a netmask). Args: ip_str: A string, the potential hostmask. Returns: A boolean, True if the IP string is a hostmask. rÔcsg|]}|ˆjkr|‘qSr)Ú_valid_mask_octets)r r©)r+rrr >sz(_BaseV4._is_hostmask..Frr%Trq)rOrÕr’r@rP)r+r•r]Úpartsr)r+rÚ _is_hostmask2s z_BaseV4._is_hostmaskcCs&t|ƒjdƒddd…}dj|ƒdS)z�Return the reverse DNS pointer name for the IPv4 address. This implements the method described in RFC1035 3.5. rÔNr%z .in-addr.arparq)rNrOrÝ)r+Zreverse_octetsrrrr‚Gsz_BaseV4._reverse_pointercCs|jS)N)rc)r+rrrÚ max_prefixlenPsz_BaseV4.max_prefixlencCs|jS)N)rr)r+rrrrbTsz_BaseV4.versionN)r6r7r8r;r9rrÚ IPV4LENGTHrdÚ frozensetr�rÞrcrÑrršrÓr”rÖrŸràr‚r™rárbrrrrr�°s"    %  r�c@s|eZdZdZdZdd„Zedd„ƒZedd „ƒZed d „ƒZ ed d „ƒZ edd„ƒZ edd„ƒZ edd„ƒZ edd„ƒZdS)r=z/Represent and manipulate single IPv4 Addresses.rUÚ __weakref__cCsxt|tƒr|j|ƒ||_dSt|tƒrL|j|dƒt|ƒ}t|dƒ|_dSt|ƒ}d|krht d|ƒ‚|j |ƒ|_dS)a± Args: address: A string or integer representing the IP Additionally, an integer can be passed, so IPv4Address('192.0.2.1') == IPv4Address(3221225985). or, more generally IPv4Address(int(IPv4Address('192.0.2.1'))) == IPv4Address('192.0.2.1') Raises: AddressValueError: If ipaddress isn't a valid IPv4 address. Nrr rMzUnexpected '/' in %r) rrr†rUr?r‡rrrNr:r”)r+rAÚbvsÚaddr_strrrrr¥_s      zIPv4Address.__init__cCs t|jƒS)z*The binary representation of this address.)rKrU)r+rrrÚpackedƒszIPv4Address.packedcCs ||jjkS)z°Test if the address is otherwise IETF reserved. Returns: A boolean, True if the address is within the reserved IPv4 Network range. )Ú _constantsÚ_reserved_network)r+rrrrÈs zIPv4Address.is_reservedcst‡fdd„ˆjjDƒƒS)z¶Test if this address is allocated for private networks. Returns: A boolean, True if the address is reserved per iana-ipv4-special-registry. c3s|]}ˆ|kVqdS)Nr)r re)r+rrrÜœsz)IPv4Address.is_private..)ÚanyrèÚ_private_networks)r+r)r+rrÅ“s zIPv4Address.is_privatecCs||jjko|j S)N)rèÚ_public_networkrÅ)r+rrrrÆžs zIPv4Address.is_globalcCs ||jjkS)z­Test if the address is reserved for multicast use. Returns: A boolean, True if the address is multicast. See RFC 3171 for details. )rèÚ_multicast_network)r+rrrrÀ¤s zIPv4Address.is_multicastcCs ||jjkS)z¤Test if the address is unspecified. Returns: A boolean, True if this is the unspecified address as defined in RFC 5735 3. )rèÚ_unspecified_address)r+rrrrǯs zIPv4Address.is_unspecifiedcCs ||jjkS)z�Test if the address is a loopback address. Returns: A boolean, True if the address is a loopback per RFC 3330. )rèÚ_loopback_network)r+rrrrȺszIPv4Address.is_loopbackcCs ||jjkS)z’Test if the address is reserved for link-local. Returns: A boolean, True if the address is link-local per RFC 3927. )rèÚ_linklocal_network)r+rrrrÄÄszIPv4Address.is_link_localN)rUrä)r6r7r8r;r9r¥r™rçrÃrÅrÆrÀrÇrÈrÄrrrrr=Ys$   r=c@sjeZdZdd„Zdd„Zdd„Zdd„Zd d „Zej Z e d d „ƒZ e d d„ƒZ e dd„ƒZ e dd„ƒZdS)rGcCsÞt|ttfƒr2tj||ƒt|jƒ|_|j|_ dSt|t ƒr–tj||dƒt |ƒdkrht |dƒ|_ n|j|_ t|dd�|_|jj |_ |jj|_dSt|ƒ}tj||dƒt|dd�|_|jj |_ |jj |_ |jj|_dS)Nrr%F)rE)rr?rr=r¥rCrUr§rcrsÚtuplerPr’r¯r²rR)r+rArQrrrr¥Ñs(        zIPv4Interface.__init__cCsd|j|jƒ|jjfS)Nz%s/%d)rŸrUr§r‰)r+rrrr ís zIPv4Interface.__str__c CsDtj||ƒ}| s|tkr|Sy |j|jkStk r>dSXdS)NF)r=r-r.r§rt)r+r,Ú address_equalrrrr-ñs  zIPv4Interface.__eq__c Cs>tj||ƒ}|tkrtSy |j|jkStk r8dSXdS)NF)r=r1r.r§rt)r+r,Ú address_lessrrrr1ýs  zIPv4Interface.__lt__cCs|j|jAt|jjƒAS)N)rUrsr’r§ru)r+rrrr£szIPv4Interface.__hash__cCs t|jƒS)N)r=rU)r+rrrrZ szIPv4Interface.ipcCsd|j|jƒ|jfS)Nz%s/%s)rŸrUrs)r+rrrr³s zIPv4Interface.with_prefixlencCsd|j|jƒ|jfS)Nz%s/%s)rŸrUr¯)r+rrrr´s zIPv4Interface.with_netmaskcCsd|j|jƒ|jfS)Nz%s/%s)rŸrUr²)r+rrrrµs zIPv4Interface.with_hostmaskN)r6r7r8r¥r r-r1r£r~r˜r™rZr³r´rµrrrrrGÏs     rGc@s*eZdZdZeZddd„Zedd„ƒZdS) rCaeThis class represents and manipulates 32-bit IPv4 network + addresses.. Attributes: [examples for IPv4Network('192.0.2.0/27')] .network_address: IPv4Address('192.0.2.0') .hostmask: IPv4Address('0.0.0.31') .broadcast_address: IPv4Address('192.0.2.32') .netmask: IPv4Address('255.255.255.224') .prefixlen: 27 TcCs|tj||ƒt|ttfƒrrŠ)rˆrÒr‰r¯rrrrÓÊs   z_BaseV6._make_netmaskcCsâ|s tdƒ‚|jdƒ}d}t|ƒ|kr:d||f}t|ƒ‚d|dkr´yt|jƒƒj}Wn2tk rŠ}ztd||fƒ‚WYdd}~XnX|jd |d ?d @ƒ|jd |d @ƒ|jd}t|ƒ|krâd |d|f}t|ƒ‚d}x@tdt|ƒdƒD]*} || sú|dk �r d |}t|ƒ‚| }qúW|dk �rÊ|} t|ƒ|d} |d�sn| d8} | �rnd}t||ƒ‚|d�s–| d8} | �r–d}t||ƒ‚|j| | } | dk�r4d}t||jd|fƒ‚njt|ƒ|jk�rðd}t||j|fƒ‚|d�s d}t||ƒ‚|d�s$d}t||ƒ‚t|ƒ} d} d} ytd} x,t | ƒD] } | d K} | |j || ƒO} �qDW| d | K} x0t | dƒD] } | d K} | |j || ƒO} �q‚W| St k �rÜ}ztd||fƒ‚WYdd}~XnXdS)zùTurn an IPv6 ip_str into an integer. Args: ip_str: A string, the IPv6 ip_str. Returns: An int, the IPv6 address Raises: AddressValueError: if ip_str isn't a valid IPv6 Address. zAddress cannot be emptyú:rØz At least %d parts expected in %rrÔr%z%s in %rNz%xriÿÿz!At most %d colons permitted in %rz At most one '::' permitted in %rrz0Leading ':' only permitted as part of '::' in %rz1Trailing ':' only permitted as part of '::' in %rz/Expected at most %d other parts with '::' in %rz,Exactly %d parts expected without '::' in %rrqrqrq) r:rOrPr=rhrUrkÚ _HEXTET_COUNTr)ÚrangeÚ _parse_hextetr@)rˆr•rßZ _min_partsr…Zipv4_intr×Z _max_partsZ skip_indexr!Zparts_hiZparts_loZ parts_skippedr‹rrrr”Üs†    "              z_BaseV6._ip_int_from_stringcCs>|jj|ƒstd|ƒ‚t|ƒdkr4d}t||ƒ‚t|dƒS)a&Convert an IPv6 hextet string into an integer. Args: hextet_str: A string, the number to parse. Returns: The hextet as an integer. Raises: ValueError: if the input isn't strictly a hex number from [0..FFFF]. zOnly hex digits permitted in %rrz$At most 4 characters permitted in %rr)Ú _HEX_DIGITSr‘r@rPr’)rˆZ hextet_strr…rrrrúEs     z_BaseV6._parse_hextetc Cs¦d}d}d}d}xJt|ƒD]>\}}|dkrP|d7}|dkr>|}||krX|}|}qd}d}qW|dkr¢||}|t|ƒkr‚|dg7}dg|||…<|dkr¢dg|}|S) aäCompresses a list of hextets. Compresses a list of strings, replacing the longest continuous sequence of "0" in the list with "" and adding empty strings at the beginning or at the end of the string such that subsequently calling ":".join(hextets) will produce the compressed version of the IPv6 address. Args: hextets: A list of strings, the hextets to compress. Returns: A list of strings. r%rrÛÚrqrqrqrq)Ú enumeraterP) rˆÚhextetsZbest_doublecolon_startZbest_doublecolon_lenZdoublecolon_startZdoublecolon_lenÚindexZhextetZbest_doublecolon_endrrrÚ_compress_hextets_s.   z_BaseV6._compress_hextetsNcsZ|dkrt|jƒ}||jkr$tdƒ‚d|‰‡fdd„tdddƒDƒ}|j|ƒ}d j|ƒS) a,Turns a 128-bit integer into hexadecimal notation. Args: ip_int: An integer, the IP address. Returns: A string, the hexadecimal representation of the address. Raises: ValueError: The address is bigger than 128 bits of all ones. NzIPv6 address is too largez%032xcs&g|]}dtˆ||d…dƒ‘qS)z%xrr)r’)r r©)Úhex_strrrr ¤sz/_BaseV6._string_from_ip_int..rrrr÷)r’rUrdr@rùrrÝ)rˆr‹rþr)rrrŸ�s   z_BaseV6._string_from_ip_intcsŒt|tƒrt|jƒ}nt|tƒr,t|jƒ}nt|ƒ}|j|ƒ}d|‰‡fdd„tdddƒDƒ}t|ttfƒr‚ddj |ƒ|j fSdj |ƒS) z¬Expand a shortened IPv6 address. Args: ip_str: A string, the IPv6 address. Returns: A string, the expanded IPv6 address. z%032xcsg|]}ˆ||d…‘qS)rr)r r©)rrrr ¼sz8_BaseV6._explode_shorthand_ip_string..rrrz%s/%dr÷) rrDrNrurHrZr”rùryrÝrs)r+r•r‹rßr)rrr©s     z$_BaseV6._explode_shorthand_ip_stringcCs&|jddd…jddƒ}dj|ƒdS)z�Return the reverse DNS pointer name for the IPv6 address. This implements the method described in RFC3596 2.5. Nr%r÷rürÔz .ip6.arparq)r€ÚreplacerÝ)r+Z reverse_charsrrrr‚Ász_BaseV6._reverse_pointercCs|jS)N)rc)r+rrrráÊsz_BaseV6.max_prefixlencCs|jS)N)rr)r+rrrrbÎsz_BaseV6.version)N)r6r7r8r;r9rrÚ IPV6LENGTHrdrørãrûrcrÑršrÓr”rúrrŸrr‚r™rárbrrrrrõ¶s$   i  0  rõc@s¬eZdZdZdZdd„Zedd„ƒZedd „ƒZed d „ƒZ ed d „ƒZ edd„ƒZ edd„ƒZ edd„ƒZ edd„ƒZedd„ƒZedd„ƒZedd„ƒZedd„ƒZdS) r>z/Represent and manipulate single IPv6 Addresses.rUräcCsxt|tƒr|j|ƒ||_dSt|tƒrL|j|dƒt|ƒ}t|dƒ|_dSt|ƒ}d|krht d|ƒ‚|j |ƒ|_dS)aInstantiate a new IPv6 address object. Args: address: A string or integer representing the IP Additionally, an integer can be passed, so IPv6Address('2001:db8::') == IPv6Address(42540766411282592856903984951653826560) or, more generally IPv6Address(int(IPv6Address('2001:db8::'))) == IPv6Address('2001:db8::') Raises: AddressValueError: If address isn't a valid IPv6 address. Nrr rMzUnexpected '/' in %r) rrr†rUr?r‡rrrNr:r”)r+rArårærrrr¥Ùs      zIPv6Address.__init__cCs t|jƒS)z*The binary representation of this address.)rLrU)r+rrrrçþszIPv6Address.packedcCs ||jjkS)z»Test if the address is reserved for multicast use. Returns: A boolean, True if the address is a multicast address. See RFC 2373 2.7 for details. )rèrí)r+rrrrÀs zIPv6Address.is_multicastcst‡fdd„ˆjjDƒƒS)zµTest if the address is otherwise IETF reserved. Returns: A boolean, True if the address is within one of the reserved IPv6 Network ranges. c3s|]}ˆ|kVqdS)Nr)r r©)r+rrrÜsz*IPv6Address.is_reserved..)rêrèÚ_reserved_networks)r+r)r+rrÃs zIPv6Address.is_reservedcCs ||jjkS)z�Test if the address is reserved for link-local. Returns: A boolean, True if the address is reserved per RFC 4291. )rèrð)r+rrrrÄszIPv6Address.is_link_localcCs ||jjkS)a`Test if the address is reserved for site-local. Note that the site-local address space has been deprecated by RFC 3879. Use is_private to test if this address is in the space of unique local addresses as defined by RFC 4193. Returns: A boolean, True if the address is reserved per RFC 3513 2.5.6. )rèÚ_sitelocal_network)r+rrrÚ is_site_local#s zIPv6Address.is_site_localcst‡fdd„ˆjjDƒƒS)z¶Test if this address is allocated for private networks. Returns: A boolean, True if the address is reserved per iana-ipv6-special-registry. c3s|]}ˆ|kVqdS)Nr)r re)r+rrrÜ:sz)IPv6Address.is_private..)rêrèrë)r+r)r+rrÅ1s zIPv6Address.is_privatecCs|j S)z¹Test if this address is allocated for public networks. Returns: A boolean, true if the address is not reserved per iana-ipv6-special-registry. )rÅ)r+rrrrÆ<s zIPv6Address.is_globalcCs |jdkS)z¨Test if the address is unspecified. Returns: A boolean, True if this is the unspecified address as defined in RFC 2373 2.5.2. r)rU)r+rrrrÇGs zIPv6Address.is_unspecifiedcCs |jdkS)z±Test if the address is a loopback address. Returns: A boolean, True if the address is a loopback address as defined in RFC 2373 2.5.3. r%)rU)r+rrrrÈRs zIPv6Address.is_loopbackcCs |jd?dkrdSt|jd@ƒS)z¶Return the IPv4 mapped address. Returns: If the IPv6 address is a v4 mapped address, return the IPv4 mapped address. Return None otherwise. riÿÿNlÿÿ)rUr=)r+rrrÚ ipv4_mapped]s zIPv6Address.ipv4_mappedcCs4|jd?dkrdSt|jd?d@ƒt|jd@ƒfS)zÛTuple of embedded teredo IPs. Returns: Tuple of the (server, client) IPs or None if the address doesn't appear to be a teredo address (doesn't start with 2001::/32) é`i Nrlÿÿ)rUr=)r+rrrÚteredojs zIPv6Address.teredocCs$|jd?dkrdSt|jd?d@ƒS)zÎReturn the IPv4 6to4 embedded address. Returns: The IPv4 6to4-embedded address if present or None if the address doesn't appear to contain a 6to4 embedded address. épi NéPlÿÿ)rUr=)r+rrrÚ sixtofourys zIPv6Address.sixtofourN)rUrä)r6r7r8r;r9r¥r™rçrÀrÃrÄrrÅrÆrÇrÈrr r rrrrr>Ós%   r>c@s‚eZdZdd„Zdd„Zdd„Zdd„Zd d „Zej Z e d d „ƒZ e d d„ƒZ e dd„ƒZ e dd„ƒZe dd„ƒZe dd„ƒZdS)rHcCsÞt|ttfƒr2tj||ƒt|jƒ|_|j|_ dSt|t ƒr–tj||dƒt |ƒdkrht |dƒ|_ n|j|_ t|dd�|_|jj |_ |jj|_dSt|ƒ}tj||dƒt|dd�|_|jj |_ |jj |_ |jj|_dS)Nrr%F)rE)rr?rr>r¥rDrUr§rcrsrñrPr’r¯r²rR)r+rArQrrrr¥‰s(        zIPv6Interface.__init__cCsd|j|jƒ|jjfS)Nz%s/%d)rŸrUr§r‰)r+rrrr ¡s zIPv6Interface.__str__c CsDtj||ƒ}| s|tkr|Sy |j|jkStk r>dSXdS)NF)r>r-r.r§rt)r+r,ròrrrr-¥s  zIPv6Interface.__eq__c Cs>tj||ƒ}|tkrtSy |j|jkStk r8dSXdS)NF)r>r1r.r§rt)r+r,rórrrr1±s  zIPv6Interface.__lt__cCs|j|jAt|jjƒAS)N)rUrsr’r§ru)r+rrrr£¼szIPv6Interface.__hash__cCs t|jƒS)N)r>rU)r+rrrrZÁszIPv6Interface.ipcCsd|j|jƒ|jfS)Nz%s/%s)rŸrUrs)r+rrrr³Ås zIPv6Interface.with_prefixlencCsd|j|jƒ|jfS)Nz%s/%s)rŸrUr¯)r+rrrr´Ês zIPv6Interface.with_netmaskcCsd|j|jƒ|jfS)Nz%s/%s)rŸrUr²)r+rrrrµÏs zIPv6Interface.with_hostmaskcCs|jdko|jjS)Nr)rUr§rÇ)r+rrrrÇÔszIPv6Interface.is_unspecifiedcCs|jdko|jjS)Nr%)rUr§rÈ)r+rrrrÈØszIPv6Interface.is_loopbackN)r6r7r8r¥r r-r1r£r~r˜r™rZr³r´rµrÇrÈrrrrrH‡s       rHc@s2eZdZdZeZd dd„Zdd„Zedd„ƒZ d S) rDavThis class represents and manipulates 128-bit IPv6 networks. Attributes: [examples for IPv6('2001:db8::1000/124')] .network_address: IPv6Address('2001:db8::1000') .hostmask: IPv6Address('::f') .broadcast_address: IPv6Address('2001:db8::100f') .netmask: IPv6Address('ffff:ffff:ffff:ffff:ffff:ffff:ffff:fff0') .prefixlen: 124 TcCs|tj||ƒt|ttfƒrrurÓrcr¯rsrñrPr’r@rRr”r«rª)r+rArErÒrçrQrrrr¥ísB           zIPv6Network.__init__ccs@t|jƒ}t|jƒ}x&t|d|dƒD]}|j|ƒVq(WdS)z¢Generate Iterator over usable hosts in a network. This is like __iter__ except it doesn't return the Subnet-Router anycast address. r%N)r’rurnr)r¦)r+r§r¨r©rrrrª< s  zIPv6Network.hostscCs|jjo|jjS)a`Test if the address is reserved for site-local. Note that the site-local address space has been deprecated by RFC 3879. Use is_private to test if this address is in the space of unique local addresses as defined by RFC 4193. Returns: A boolean, True if the address is reserved per RFC 3513 2.5.6. )rurrn)r+rrrrH s zIPv6Network.is_site_localN)T) r6r7r8r;r>r¦r¥rªr™rrrrrrDÝs   O rDc@sÂeZdZedƒZedƒZedƒedƒedƒedƒedƒedƒed ƒed ƒed ƒedƒg Zed ƒed ƒedƒedƒedƒedƒedƒedƒedƒedƒedƒedƒedƒedƒedƒgZedƒZdS)Ú_IPv6Constantsz fe80::/10zff00::/8z::1/128z::/128z ::ffff:0:0/96z100::/64z 2001::/23z 2001:2::/48z 2001:db8::/32z 2001:10::/28zfc00::/7z::/8z100::/8z200::/7z400::/6z800::/5z1000::/4z4000::/3z6000::/3z8000::/3zA000::/3zC000::/3zE000::/4zF000::/5zF800::/6zFE00::/9z fec0::/10N) r6r7r8rDrðrírërrrrrrr X s*         r r)r%)T)8r;Ú __future__rr#rÚ __version__r’rZlongÚ NameErrorÚunicoderNÚstrr?rrÚ from_bytesrrtrrÁr"r)Úobjectr*rârr@r:r<rBrFrIrKrLrRr[r^rfrprxr}r~r`ryr�r=rGrCrôrèrõr>rHrDr rrrrÚ s„        )$ $#716=`*vRr 5V{!